My first Microscope and Questions

What equipment do you use? Post pictures and descriptions of your microscope(s) here!
Post Reply
Message
Author
qlog
Posts: 8
Joined: Wed Jun 24, 2020 7:26 pm

My first Microscope and Questions

#1 Post by qlog » Thu Jul 02, 2020 11:53 pm

Just received the microscope and first impression, Olympus BH2 BHTU is built like a tank, came with DPlan Objectives 4,10,20,40,60 and a teaching head, I added the eye pieces on teaching head did a little wipedown and it looks like ready to go. PeteM, it came with a MTV adapter and 2.5x lens for trinocluar which is a fantastic BONUS. Everything seems to be working, and I was able to focus using all objectives on a fleck of Oregano (pic attached 600x obj using cell phone on eyepiece) and a fleck of Ginger skin (4x Obj).

Question
(1) the pre focus lock lever doesn't move, it's on the left coarse knob any ideas, I am not even sure if its something that is supposed to move.
(2) other than the BH2 body i didn't clean anything optics yet, what cleaner should I use. what I have handy is contact eye lens solution. would it be safe to qtip using that solution.
(3) any ideas on eye piece covers (all eyepiece rubbers are missing)

Pictures attached, thanks guys for sharing your ideas and knowledge.
IMG_20200702_161106.jpeg
IMG_20200702_161106.jpeg (228.68 KiB) Viewed 826 times
IMG_20200702_161121.jpeg
IMG_20200702_161121.jpeg (262.5 KiB) Viewed 826 times
IMG_20200702_161043.jpeg
IMG_20200702_161043.jpeg (228.91 KiB) Viewed 826 times
oreganoFleck600x.jpeg
oreganoFleck600x.jpeg (214.99 KiB) Viewed 807 times
Attachments
IMG_20200702_153304.jpeg
IMG_20200702_153304.jpeg (296.32 KiB) Viewed 826 times

Post Reply